Heartbleed Bug Patch

Posted by Dodd Caldwell · Apr 10, 2014

You may have read recently about the Heartbleed bug that exposed a vulnerability in OpenSSL, the encryption software that much of the internet uses for security purposes.

We wanted to let you know that there have been no known compromises in our system and that we’ve addressed the issue within our infrastructure. In addition, our third party payment processor, Stripe, has also addressed the issue on their end.

If you have a MoonClerk account and would like, you can update your login credentials. Please contact us if you have any additional questions.

 

You´re just 5 minutes away
from accepting recurring and one-time online payments

Explore for Free